Small Bugs

Discussion in 'Support' started by Mycal, Dec 11, 2010.

  1. Mycal

    Mycal Staff Member

    This to simply compose a list of small bugs that I've noticed while fixing other things and haven't had time to fix.

    1- Closing the server doesn't close it immediately, it still takes awhile some times
    2- Sometimes after the server is closed, it will give an error message some time after it was initially closed (you can safely ignore it for now)
    3- The private server form on the client is very buggy. Make sure all fields have valid data or it will crash.
    4- If you cancel the private server form, you will not be able to connect to the server you previously chose (if started from registry) and it may or may not crash when you try to connect
    5- The updater is VERY slow in receiving the list of servers. It may appear to have frozen, but give it time, it does work.

    If you've noticed anything else, feel free to post a reply with what you've found.
     
  2. TheCord

    TheCord New Member

    I'll try and get a list of bugs going as I mess around with the server.

    Bugs:
    -I had an item give a playermessage when someone tried to pick it up. Two of these items were on the same tile and when I tried to pick them up it flooded the message and crashed the server.

    -My server shows up on the registry list but when I try to connect to it I recieve "Run-time Error '75': Path/File access error". I can still connect using the connector though.

    -When you press BOX with the map editor it makes whatever you have selected be every tile of the map. It was meant to do this when you double click BOX. This makes BOX pretty much unusable.

    -Whenever the server crashes for whatever reason. If I try to reboot it I constantly get the "Run-timer Error '55'" or whatever that says it is already open.

    -Client side bug: When you use the strength in the object editor for armor, shields, and helmets rather than reducing damage it randomly has monsters do 0's to you. If you use the modifies though and set it to armor it works fine.

    -When you execute a script it doesn't always run in order. If I were to put three playermessages such as:
    Code:
    Sub Main(Player AS LONG)
    PlayerMessage(Player, "Hi,", white)
    PlayerMessage(Player, "What's up?", white)
    PlayerMessage(Player, "Bye.", white)
    End Sub
    It may display
    Code:
    Hi,
    Bye.
    What's up?
    Or something of the sort.
     
  3. Mycal

    Mycal Staff Member

    Added to the list to be looked at. For the script, since Steverino didn't give me the scripting code (I'm still under the suspicion that he doesn't have access to that portion, I believe Bugaboo was the only one who worked on that end and just gave him the executables [mbsc.exe and script.dll]), I can only make minor changes to the scripting and not fix major errors like that. Perhaps I should bug him again and ask if he does have the code just to be sure.
     
  4. TheCord

    TheCord New Member

    -When I switch maps sometimes I walk two steps. It's sloppy. But this also causes me to sometimes walk through walls on the map that I am joining. (This walking through walls may only occur when I haven't visited the map yet so it hasn't saved having seen the map or whatever.)
     
  5. Mycal

    Mycal Staff Member

    That's actually a bug I introduced when fixing a few other old known bugs so that should be easy to fix. The rest I'm working on, but I need clarification on one of the ones you reported.

    When accessing the server the the registry, does this error happen from the Updater or the Client (Does it happen after you click Connect and before the Client shows)?
     
  6. TheCord

    TheCord New Member

    After the updater would run and I would try to select a certain server on the list.
     

Share This Page