Just some concerns...

Discussion in 'Support' started by TheCord, Nov 10, 2010.

  1. TheCord

    TheCord New Member

    I don't know how work on this is going since I know you don't really plan on doing much, but I am unable to log on to a server. I can get the server running but when I try to log on it'll stay stuck at "Connecting" if I am trying to log on, or "Sending.." whatever if I am trying to Create a New Account.
    I'm not sure what I'm missing, I'm pretty sure I got all the updates and what not. Even if I try to use an old version of odyssey that this new one is based off of I get the same result.

    Regards, TheCord
     
  2. Mycal

    Mycal Staff Member

    First I apologize for the late approval of your posts. The permissions on this forum are very screwed up, I'll look into that. If you post again and it doesn't show up, simply PM me again and I'll approve them when I get a chance.

    As for your problems, I'll look into them. Could you tell me what Operating System you are on as well as if you have installed the dependency package? I'm honestly a little surprised the older versions would even work for you. If you are on anything past Windows XP there are well known issues with the winsock code. There are some very big changes in my version of the server & client compared to the older versions so they are totally incompatible. In fact, the server uses a totally different socket library which I know does not work with the older client. No idea if the latest client would work with an older server though.. :\
     
  3. TheCord

    TheCord New Member

    Yes I have installed the dependency package. I've tried on my old XP as well as on my Vista. What I've been doing is running the old server version off my XP and your client version and they work together. I got all the files off odyssey.burningstormstudios.com so if there are all up to date that I have no idea what could be wrong.

    [Edit]: Posting is working, didn't mean to bother you by PMing you but I wasn't sure if I was ever going to be approved or what.

    [Edit 2]: If I keep it trying to connect long enough I get the error "Run-time error '40020': Invalid operation at current state."
     
  4. Mycal

    Mycal Staff Member

    OK, I've done a lot of testing and have not been able to replicate this problem. If you are running a local server then you may be having problems with ports (my router blocks all ports by default and I have to port forward everything), but otherwise, it should be working fine. I've tried connecting to a local server by simply running ody.exe and it works. I've tried running a remote server by using the registry and it also works fine. I've even tried just running ody.exe from a totally different location and manually entering the ip using the credits page>private server. Still no problems.

    The only real problem I have seen is when my internet drops on my development machine. After that the server refuses any and all connections until it is restarted. This probably means that servers without any kind of internet will not work, but that's not really a server then is it?
     
  5. TheCord

    TheCord New Member

    I redownloaded the server and it seems to work fine. Thanks.
     

Share This Page