Run-time error '55'

Discussion in 'Support' started by Fishies, Nov 30, 2010.

  1. Fishies

    Fishies New Member

    Run-time error '55' File already open.

    This occurs whenever I try to host a server. I have tried this on Windows 7 (64 bit), Windows Vista, and Windows XP (Virtual Machine on my Windows 7 desktop) and I still get this error.
     
  2. Mycal

    Mycal Staff Member

    Hello, I've uploaded a new version that should fix this problem. If you are still encountering the issue here is how you can fix it temporarily:

    Get it here (only server was updated):
    http://odyssey.burningstormstudios.com/?downloads

    Open your server folder and find the file called Server.ini.
    - Open server.ini
    - Find the line UseRegOnLoad and change it to False.
    - Restart the server and it should be fixed.
     
  3. Fishies

    Fishies New Member

    great! I'm no longer receiving this error. :)

    however, now when I try to run server.exe, I get Run-time error '429': ActiveX component can't create object

    I also seem to get Run-time error '91' after running server.exe for the first time
     
  4. Mycal

    Mycal Staff Member

    for both errors, make sure that you've downloaded the dependencies package and properly installed them (registerfiles should do the majority but you may also need to run the vb runtimes file in it too). In particular, make sure that ComSocketServer is properly placed in system32 or syswow64 (if on 64bit) and registered.
     
  5. Fishies

    Fishies New Member

    thanks! it works after registering COMSocketServer.dll

    as a suggestion, you should put COMSocketServer.dll in the dependencies package zip so it's more convenient to register
     
  6. Mycal

    Mycal Staff Member

    Honestly I'm not sure why it's not already in there. But suggestion taken and it will be moved into it.
     

Share This Page